Can't Launch Game - "Data folder not found" even after a reinstall (yes, I do indeed have a Scrolls_Data folder next to the exe)

  • #1

    When I launch scrolls.exe (either from the start menu or manually through C:\Users\8b!t\AppData\Local\Mojang\Scrolls\scrolls.exe // C:\Users\8b!t\AppData\Local\Mojang\Scrolls\game\scrolls.exe), I get an error that displays "Data folder not found...There should be 'Scrolls_Data' folder next to the executable".

    I have a Scrolls_Data folder next to Scrolls.exe, and it's 9.6mb in size, not empty. I've tried deleting the folder and repairing the installation, manually deleting scrolls and reinstalling, and fully uninstalling/reinstalling through the installer itself. I get the same error each time.

    Here is a screenshot: http://i.imgur.com/8uS96V8.png

    Here is a video of the error and my Scrolls installation to help clarify: http://youtu.be/a8rIbuuD5xE

    I'm out of ideas... can anyone help? Let me know if you need any more information. I'd like to play Scrolls :(

    Other information: Win7 x64. Installer comes directly from the Mojang account page. No firewall/antivirus. Running as administrator doesn't help.

     

    I got the same error on an x32 Windows XP laptop. I'm seriously confused.

     

    edit: first post on page 2 is a fix that works for me.

    Last edited by Nydhoggur: 7/19/2013 12:33:30 AM
  • #2

    I have the exact same problem and I don't know how to fix it. I have tried to reinstall the file with same problem. I watched your YouTube video and double checked the location of my files. Like you, there is a Scrolls_Data file with data in it right beside of the Scrolls execution. Still, I can't launch the game.

    My operating system is also a Win7 x64.

    Last edited by YolandoGlee: 6/4/2013 8:08:26 AM
  • #3

    Out of curiosity, 

    What happens when you install into, say your program files, as opposed to your users folder?

    Stupid. Ignore that.

    When you reinstalled the game, did you also redownload it?

     

  • #4

    no, I didn't redownload it. I used the file from first download. I can retry downloading it to see if that makes a difference. 

  • #5

    I'd try that if its not a huge inconvenience. Its possible your download was corrupted and therefore the installation was bound to fail.

    If it doesnt work we can try other things.

  • #6

    I'm having just the same problem. Windows 7, x64... though the OP said he tried on an x32 XP laptop so that's probably not it.

    I am going to reinstall and redownload, but I doubt it'll help. Ah well, gotta try everything.

  • #7

    I redownloaded the file fresh from the website and reinstalled again. Same result. My computer is a Dell XPS about 2 years old, fast with no issues that I know of. 

  • #8

    Are you an administrator on your computer?

  • #9

    Yes I am. 

  • #10

    The only thing I can figure is the pathing for the game isn't set properly.

    Are you running the exe from a shortcut or from the game folder?

  • #11

    Try moving the folder from the AppData location to a spot on the C drive.  Then try running the exe from that location.

  • #12

    Okay, downloaded a new installer, used it to repair Scrolls (that was an option in the installer), and used the executable (in \AppData\Local\Mojang\Scrolls\scrolls.exe) to download it again. The command prompt downloader proceeded to unpack and launch the game sucessfully... it's running right now.

    Not sure what I did, but aside from download it again, but it's working now, so all is good. All I can say is, watch the cmd prompt that downloads the game very closely this time. :)

  • #13

    Glad to hear it is working for you.  Now go enjoy the game! :)

  • #14

    Congrats Cycloneblaze that it worked for you at least. I have tried reinstalling five times, even launching it as you suggest n \AppData\Local\Mojang\Scrolls\scrolls.exe, trying the repair option several times. Still same error. 

    I did borrow a relative's computer and downloaded the game through the same internet connection I used for my computer. Scrolls worked on the other computer. But as that computer is not mine, I can not play Scrolls much on it. I need the game to run on my main computer. 

  • #15

    I finally got scrolls to play, but in a strange way. I was looking in  \AppData\Local\Mojang\Scrolls and noticed a zip file called "game". I opened it with WinRar and saw it was the zipped game (though there is also an unzipped version of the game on my computer too from the download). 

    Within WinRar, I clicked on Scrolls.exe and it allowed me to play the game. I then made a copy of the zip folder, moving it to my desktop and unzipping it. This version also allows me to play the game. 

    There is still the "data not found" error if I click the original desktop icon for Scrolls or the one that that appears in as \AppData\Local\Mojang\Scrolls\scrolls.exe.

    From this experience, it seems to me that there is some unknown error in the unpacking stage right after the download of the game. It creates a zipped and unzipped version at the same time, leading to errors. 

    At least I can play the game now. Hopefully this info will help anyone else having similar problems. 

     

     

  • #16

    OK, I fixed the issue. Repairing, moving the folder, redownloading, etc didn't work for me either.

    First, I uninstalled the game using the windows "uninstall programs" process.

    Then, I went into the appdata/mojang folder only to find that everything was deleted except for a game.zip file.

    I manually unzipped the file (110ish MB), opened the new game folder, and double clicked Scrolls.exe.

    This time, it worked!

    Others with the issue please confirm this works, and please link this thread to other players that have the problem in the future, thanks guys!

  • #17

    Yes, I'm pretty sure that's what went wrong. After scrolls.exe downloads the game files, it attempts to unpack them, and I think that's what failed for us. So you can either try the download/unpack process again, or unpack game.zip yourself, with WinZip or WinRAR or something.

    I hope this thread helps others with the same problem. That'd be cool. :)

  • #18

    Had the same issue after an update - unzipping game.zip fixed the issue thx for the help

  • #19

    Thanks man! That totally worked.

    If anybode else enounters "There should be 'Scrolls_Data' folder next to the executable", just unzip your game manually from Application Data/Mojang/Scrolls/game.zip

    (In my Case, the installer was stuck in that weird way because I'm running the game on Linux & Wine and... something exploded)

  • #20

    Nydhoggur's method worked for me too

  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes